Degraded Performance Across Propeller Services

Incident Report for Propeller

Resolved

AWS has restored its affected services and all Propeller services are back to normal.
Posted Oct 20, 2025 - 09:46 UTC

Identified

We are currently investigating degraded performance across the Propeller platform, including data processing and the mobile app. This appears to be related to a widespread Amazon Web Services (AWS) outage that is affecting multiple services.

Our team is actively monitoring the situation and the AWS status. At this time, AWS has not provided an estimated time for resolution.

Customers may experience slowness, timeouts, or errors when using the platform. We will provide further updates as more information becomes available.
Posted Oct 20, 2025 - 07:44 UTC
This incident affected: Propeller Portal, Data Processing, AeroPoints, and Propeller Mobile.