"Upload" Outage

Incident Report for Propeller

Resolved

This incident has been resolved, and all users can resume dataset uploads as normal.
Posted Oct 21, 2025 - 22:43 UTC

Update

We are currently experiencing an issue with dataset uploads due to a third-party email error.
The problem has been identified, and a fix is being implemented.
Posted Oct 21, 2025 - 22:13 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 22:02 UTC
This incident affected: Data Processing.