Propeller Down: Service Unavailable

Incident Report for Propeller

Resolved

Propeller is now available.
Posted Apr 06, 2026 - 23:42 UTC

Monitoring

We are currently deploying a fix to address the issue.
Posted Apr 06, 2026 - 23:40 UTC

Investigating

Propeller is currently unavailable and showing a “Service Unavailable” message. We’re working to bring it back online.
Posted Apr 06, 2026 - 23:34 UTC
This incident affected: Propeller Portal.