Propeller Mobile App Media Upload Issues

Incident Report for Propeller

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 01:19 UTC

Investigating

We are currently investigating an issue affecting media uploads on mobile devices.

Some users may experience the upload flow closing unexpectedly after selecting a photo from their device’s media gallery, preventing the upload from completing.

Our engineering team has identified the issue and is actively working on a fix.
Posted Feb 23, 2026 - 00:35 UTC
This incident affected: Propeller Mobile.