We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 15:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 04:58 UTC
Update
We are continuing to repair the platform after a major Amazon Web Services outage
Posted Oct 21, 2025 - 02:29 UTC
Update
We are continuing to repair the platform after a major Amazon Web Services outage
Posted Oct 21, 2025 - 02:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:04 UTC
Identified
Amazon Web Services (AWS) is experiencing a severe outage which is impacting a number of Propeller services. Some fixes have been implemented, but users still might experience degraded performance across the platform.
Posted Oct 20, 2025 - 16:02 UTC
This incident affected: Propeller Portal, Data Processing, AeroPoints, Propeller Mobile, DirtMate, Knowledge Base, WMTS, and Public API.