Uploader not loading

Incident Report for Propeller

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 00:58 UTC

Investigating

Propeller is experiencing an issue on the dataset upload page where uploads remain stuck in a loading state.

Some users may see the uploader load endlessly and be unable to proceed with their uploads.

Our team is investigating the issue and working on a fix. Updates will be shared as they become available.
Posted Feb 20, 2026 - 00:57 UTC
This incident affected: Propeller Portal.